2008/09/27

Morph AppSpace利用時には、jdkのバージョンに注意

最近ほんとにmorphのネタしか書いてないですが。かなり前に引っかかったので、メモ。

Morph Appspaceサーバーを利用する際には、jdkのバージョンに注意。

具体的には、どうやらサーバー上はjava1.5バージョンで動作している模様。したがってjava1.6バージョンを使用したりしていた場合には、バージョン違いのエラーが発生してしまうことがある。

どうやら以下のケースで発生する模様。

  • java1.6の構文を利用している。
  • 他pluginを使用している。(i18n-templatesは大丈夫っぽい。acegiやquartzはだめだった)

プラグインを使用していた場合でも、jdk1.5コンパイル->war作成->アップすると、問題なく動作しました。

0 件のコメント:

コメントを投稿